composer install 错误处理Your configuration does not allow connections

composer install 错误处理Your configuration does not allow connections

[Composer\Downloader\TransportException]
Your configuration does not allow connections to http://packagist.phpcompos
er.com/packages.json. See https://getcomposer.org/doc/06-config.md#secure-h
ttp for details.

这个问题,其实是composer 默认走https 所以你需要关闭这个https的选项。

composer config secure-http false

或者编辑你的composer.json文件,添加如下行

"config": {
    "secure-http": false
}

 

打赏 赞(1)
微信
支付宝
微信二维码图片

微信扫描二维码打赏

支付宝二维码图片

支付宝扫描二维码打赏

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据